NTP SERVER

/boot/config.txt
#GPS config
dtoverlay=pps-gpio,gpiopin=18
#Disable Bluetooth
dtoverlay=pi3-disable-bt
/boot/cmdline.txt

console=serial0,115200 を削除

sudo systemctl disable bluetooth.service
sudo systemctl disable hciuart.service
sudo vi /etc/default/gpsd
# Start the gpsd daemon automatically at boot time
START_DAEMON="true"

# Use USB hotplugging to add new USB devices automatically to the daemon
USBAUTO="false"

# Devices gpsd should collect to at boot time.
# They need to be read/writeable, either by user gpsd or the group dialout.
DEVICES="/dev/pps0 /dev/ttyAMA0"

# Other options you want to pass to gpsd
GPSD_OPTIONS="-n"
sudo systemctl enable gpsd
sudo systemctl start gpsd
/etc/ntp.conf

#pps-Only
#server 127.127.22.0 minpoll 4 maxpoll 4
#fudge 127.127.22.0 flag3 1 refid PPS
#tos mindist 0.2


#PPS Kernel mode
server 127.127.22.0 minpoll 4 maxpoll 4 true
fudge 127.127.22.0 flag3 1 refid PPS

# GPS (SMH)
server 127.127.28.0 minpoll 4 maxpoll 4 iburst prefer
fudge 127.127.28.0 flag1 1 time1 refid GPS stratum 15

# Fix False tickers
tos mindist 0.2

ESXI UNMAP

esxcli storage core device vaai status get // 一覧

esxcli storage core device list -d t10*** 詳細

esxcli storage core device vaai status set -D 1 -d t10***  //有効 Delete Status

esxcli storage core device vaai status set -D 0 -d t10***  //無効
Delete Status

esxcli storage core device vaai status set -Z 1 -d t10***  //有効 zeroStatus

esxcli storage core device vaai status set -Z0 -d t10***  //無効
zero Status

がESXI6.0かつINTEL750で有効にすると紫画面で死ぬ。

ESXI THIN

vmkfstools -K ファイル名.vmdk

windowsの場合
https://technet.microsoft.com/ja-jp/sysinternals/sdelete.aspx
sdelete64.exe -z c:

Linux:

vmkfstools -i <ファイル名.vmdk> -d thin 変換後ファイル名.vmdk

CISCO firm update

catalyst C2960L
archive download-sw /overwrite /reload ftp://username:password@ホスト/ファイル名.tar

*アカウントさえ作れればファームはダウンロード可能。

C841M
copy ftp://username:password@ホスト/ファイル名.bin flash:

本体へのコピーのみ。

適当なFTPサーバー(標準ポート用意すること)

C841M 設定 L2TP/IPSEC + PPPOE + NAT + CBAC

これでスループット上り下り130Mbpsくらい。。
L2TP接続時はMAX20Mbpsレベル。

!
aaa new-model
!
aaa authentication login local_access local
aaa authentication ppp default local
aaa authentication ppp VPDN_AUTH local
!
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.10.10.100 10.10.10.120
!
ip dhcp pool ccp-pool
 import all
 network 10.10.10.0 255.255.255.128
 default-router 10.10.10.1 
 dns-server 10.10.10.1 
 lease 0 2
!
ip inspect name CBAC tcp router-traffic
ip inspect name CBAC udp router-traffic
ip inspect name CBAC icmp router-traffic
ip cef
no ipv6 cef
!
vpdn enable
!
vpdn-group L2TP
 ! Default L2TP VPDN group
 accept-dialin
  protocol l2tp
  virtual-template 1
 no l2tp tunnel authentication
!
username **** privilege 0 password 0 ****
!
crypto keyring L2TP  
  pre-shared-key address 0.0.0.0 0.0.0.0 key *********
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
 lifetime 28800
crypto isakmp keepalive 3600
!
crypto ipsec transform-set TS1 esp-aes esp-sha-hmac 
 mode transport
!
crypto dynamic-map DYN_MAP 10
 set nat demux
 set transform-set TS1 
!
crypto map CRYP_MAP 6000 ipsec-isakmp dynamic DYN_MAP 
!
interface GigabitEthernet0/4
 description PrimaryWANDesc_
 no ip address
 ip tcp adjust-mss 1314
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Virtual-Template1
 ip unnumbered Dialer1
 ip nat inside
 ip virtual-reassembly in
 peer default ip address pool L2pool
 ppp mtu adaptive
 ppp authentication ms-chap-v2 VPDN_AUTH
!
interface Vlan1
 description $ETH_LAN$
 ip address 10.10.10.1 255.255.255.128
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1314
!
interface Dialer1
 description PrimaryWANDesc__GigabitEthernet0/4
 mtu 1454
 ip address negotiated
 ip access-group WAN-IN in
 ip nat outside
 ip inspect CBAC out
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp mtu adaptive
 ppp authentication chap pap callin
 ppp chap hostname ****
 ppp chap password 0 ****
 ppp pap sent-username **** password 0 ****
 ppp ipcp dns request
 no cdp enable
 crypto map CRYP_MAP
!
ip local pool L2pool 10.10.10.110 10.10.10.120
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp ***.***.***.*** **** interface Dialer1 *****
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended WAN-IN
 permit tcp any any eq *****
 permit udp any any eq isakmp
 permit udp any any eq non500-isakmp
 permit esp any any
 permit ahp any any
 permit udp any any eq 1701
 deny   ip any any log
!
ip sla 100
 http get http://www.****
 frequency 1200
ip sla schedule 100 life forever start-time now
dialer-list 1 protocol ip permit
!!
access-list 1 permit 10.10.10.0 0.0.0.127
!

C841M update via USB flash

CCPExpress.
yourname#dir
yourname#delete /force /recursive flash:home.shtml
yourname#delete /force /recursive flash:ccpexp
yourname#dir
yourname#copy usbflash0:ccpexpressAdmin_3_3_1_ja.tar flash:
yourname#archive tar /xtract flash:ccpexpressAdmin_3_3_1_ja.tar flash:/
yourname#dir

Firmも同様にアップロード後適用する。

参考:
https://supportforums.cisco.com/sites/default/files/attachments/document/files/ccp32_c841m_upgradeguide-pdf_0.pdf